CVE-2025-66035

Angular HTTP Client Has XSRF Token Leakage via Protocol-Relative URLs

HIGH
7.7
CVSS Score
Published: November 26, 2025 at 10:18 PM UTC
Updated: October 19, 2026 at 01:10 PM UTC
3 products affected across 2 vendors@angularRUGGEDCOM RST2428P FirmwareSIDIS Prime

Using angular by angular?

Get instant alerts when new vulnerabilities affect angular - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.7
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.16, 20.3.14, and 21.0.1, there is a XSRF token leakage via protocol-relative URLs in angular HTTP clients. The vulnerability is a Credential Leak by App Logic that leads to the unauthorized disclosure of the Cross-Site Request Forgery (XSRF) token to an attacker-controlled domain. Angular's HttpClient has a built-in XSRF protection mechanism that works by checking if a request URL starts with a protocol (http:// or https://) to determine if it is cross-origin. If the URL starts with protocol-relative URL (//), it is incorrectly treated as a same-origin request, and the XSRF token is automatically added to the X-XSRF-TOKEN header. This issue has been patched in versions 19.2.16, 20.3.14, and 21.0.1. A workaround for this issue involves avoiding using protocol-relative URLs (URLs starting with //) in HttpClient requests. All backend communication URLs should be hardcoded as relative paths (starting with a single /) or fully qualified, trusted absolute URLs.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 19.2.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.0.1, so it looks safe — our inference, not a vendor statement
v < V4.0
Affected range stops below V4.0, so it looks safe — our inference, not a vendor statement
v < V4.0.800
Affected range stops below V4.0.800, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.7HIGHGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-201CWE-359

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card