CVE-2025-65944

Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`

MEDIUM
5.1
CVSS Score
Published: November 25, 2025 at 12:23 AM UTC
Updated: October 18, 2026 at 08:10 PM UTC
1 product affected across 1 vendorSentry JavaScript

Using sentry-javascript by getsentry?

Get instant alerts when new vulnerabilities affect sentry-javascript - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.1
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 10.27.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.1MEDIUMGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-201

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card