CVE-2025-65199

Windscribe for Linux 'changeMTU' local privilege escalation

HIGH
7.8
CVSS Score
Published: December 10, 2025 at 06:04 PM UTC
Updated: September 28, 2026 at 10:10 PM UTC
1 product affected across 1 vendorWindscribe

Using Windscribe for Linux Desktop App by Windscribe?

Get instant alerts when new vulnerabilities affect Windscribe for Linux Desktop App - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.10.1 ≤ v ≤ 2.17.102.10.1 ≤ v < 2.18.3-alpha2.10.1 ≤ v < 2.18.82.10.12.18.1 alpha2.18.32.18.5
Vendor states this is fixed in 2.18.3-alpha (unaffected)
Vendor states this is fixed in 2.18.8 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.8HIGHcisa-cg
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card