CVE-2025-62427

Server-Side Request Forgery (SSRF) in Angular SSR

HIGH
8.7
CVSS Score
Published: October 16, 2025 at 06:50 PM UTC
Updated: October 9, 2026 at 10:10 AM UTC
1 product affected across 1 vendorAngular CLI

Using angular-cli by angular?

Get instant alerts when new vulnerabilities affect angular-cli - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.7
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

The Angular CLI is a command-line interface tool for Angular applications. The vulnerability is a Server-Side Request Forgery (SSRF) flaw within the URL resolution mechanism of Angular's Server-Side Rendering package (@angular/ssr) before 19.2.18, 20.3.6, and 21.0.0-next.8. The function createRequestUrl uses the native URL constructor. When an incoming request path (e.g., originalUrl or url) begins with a double forward slash (//) or backslash (\\), the URL constructor treats it as a schema-relative URL. This behavior overrides the security-intended base URL (protocol, host, and port) supplied as the second argument, instead resolving the URL against the scheme of the base URL but adopting the attacker-controlled hostname. This allows an attacker to specify an external domain in the URL path, tricking the Angular SSR environment into setting the page's virtual location (accessible via DOCUMENT or PlatformLocation tokens) to this attacker-controlled domain. Any subsequent relative HTTP requests made during the SSR process (e.g., using HttpClient.get('assets/data.json')) will be incorrectly resolved against the attacker's domain, forcing the server to communicate with an arbitrary external endpoint. This vulnerability is fixed in 19.2.18, 20.3.6, and 21.0.0-next.8.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

>=19.0.0-next.0, < 19.2.18>=20.0.0-next.0, < 20.3.6>=21.0.0-next.0, < 21.0.0-next.8
Affected range stops below 19.2.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.0.0-next.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.7HIGHGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card