CVE-2025-61673

Karapace is vulnerable to Authentication Bypass

HIGH
8.6
CVSS Score
Published: October 3, 2025 at 09:12 PM UTC
Updated: October 8, 2026 at 10:10 PM UTC
1 product affected across 1 vendorKarapace

Using karapace by Aiven-Open?

Get instant alerts when new vulnerabilities affect karapace - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Karapace is an open-source implementation of Kafka REST and Schema Registry. Versions 5.0.0 and 5.0.1 contain an authentication bypass vulnerability when configured to use OAuth 2.0 Bearer Token authentication. If a request is sent without an Authorization header, the token validation logic is skipped entirely, allowing an unauthenticated user to read and write to Schema Registry endpoints that should otherwise be protected. This effectively renders the OAuth authentication mechanism ineffective. This issue is fixed in version 5.0.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

>= 5.0.0, < 5.0.2
Affected range stops below 5.0.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.6HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
HIGH
Availability
LOW
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-306CWE-288

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card