CVE-2025-6141

GNU ncurses parse_entry.c postprocess_termcap stack-based overflow

LOW
3.3
CVSS Score
Published: June 16, 2025 at 10:00 PM UTC
Updated: June 17, 2026 at 10:01 AM UTC
13 products affected across 2 vendorsRUGGEDCOM RST2428P FirmwareScalance Xr 300SCALANCE XR-500

Using ncurses by GNU?

Get instant alerts when new vulnerabilities affect ncurses - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

A vulnerability has been found in GNU ncurses up to 6.5-20250322 and classified as problematic. This vulnerability affects the function postprocess_termcap of the file tinfo/parse_entry.c. The manipulation leads to stack-based buffer overflow. The attack needs to be approached locally. Upgrading to version 6.5-20250329 is able to address this issue. It is recommended to upgrade the affected component.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 6.5-20250329 (unaffected)
v < V3.3v < V4.0
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
Affected range stops below V4.0, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement
v < V3.3
Affected range stops below V3.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.3LOWVulDB
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-119CWE-121

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card