CVE-2025-57758

Contao has improper access control in the back end voters

MEDIUM
4.3
CVSS Score
Published: August 28, 2025 at 04:32 PM UTC
Updated: June 17, 2026 at 09:43 AM UTC
1 product affected across 1 vendorContao

Using contao by contao?

Get instant alerts when new vulnerabilities affect contao - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Contao is an Open Source CMS. In versions starting from 5.0.0 and prior to 5.3.38 and 5.6.1, the table access voter in the back end doesn't check if a user is allowed to access the corresponding module. This issue has been patched in versions 5.3.38 and 5.6.1. A workaround involves not relying solely on the voter and additionally to check USER_CAN_ACCESS_MODULE.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.3.38v < 5.6.15.3.0 ≤ v < 5.3.385.4.0 ≤ v < 5.6.1
Affected range stops below 5.3.38, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.6.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-284

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card