CVE-2025-55752

Apache Tomcat: Directory traversal via rewrite with possible RCE if PUT is enabled

HIGH
7.5
CVSS Score
Published: October 27, 2025 at 05:29 PM UTC
Updated: October 8, 2026 at 11:10 AM UTC
2 products affected across 2 vendorsTomcatSIMATIC CN 4100

Using Apache Tomcat by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Tomcat - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 64%
SSVC
No known exploit

Description

Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 10.0.27, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.1.45, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.109, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 10.0.0-M1 (unknown)
Vendor states this is fixed in 3 (unknown)
v < V5.0
Affected range stops below V5.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (5)

Vendor AdvisoryIssue Tracking
Source: cverecord
https://lists.apache.org/thread/n05kjcwyj1s45ovs8ll1qrrojhfb1tog
Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2025/10/27/4
ExploitThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
https://www.vicarius.io/vsociety/posts/cve-2025-55752-detect-apache-tomcat-vulnerability
MitigationThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
https://www.vicarius.io/vsociety/posts/cve-2025-55752-mitigate-apache-tomcat-vulnerability
Source: 0b142b55-0307-4c5a-b3c9-f314f3fb7c5e
https://cert-portal.siemens.com/productcert/html/ssa-032379.html

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-23

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card