CVE-2025-55282

aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration

HIGH
7.2
CVSS Score
Published: August 18, 2025 at 04:44 PM UTC
Updated: June 17, 2026 at 09:41 AM UTC
1 product affected across 1 vendorAiven DB Migrate

Using aiven-db-migrate by aiven?

Get instant alerts when new vulnerabilities affect aiven-db-migrate - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.0.7
Affected range stops below 1.0.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card