CVE-2025-54365

fastapi-guard patch contains bypassable RegEx

HIGH
7.5
CVSS Score
Published: July 23, 2025 at 10:11 PM UTC
Updated: June 17, 2026 at 09:39 AM UTC
2 products affected across 2 vendorsFastapi GuardFastapi Guard

Using fastapi-guard by rennf93?

Get instant alerts when new vulnerabilities affect fastapi-guard - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.9%
SSVC
PoC

Description

fastapi-guard is a security library for FastAPI that provides middleware to control IPs, log requests, detect penetration attempts and more. In version 3.0.1, the regular expression patched to mitigate the ReDoS vulnerability by limiting the length of string fails to catch inputs that exceed this limit. This type of patch fails to detect cases in which the string representing the attributes of a <script> tag exceeds 100 characters. As a result, most of the regex patterns present in version 3.0.1 can be bypassed. This is fixed in version 3.0.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.0.2
Affected range stops below 3.0.2, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-20CWE-185CWE-1333

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card