CVE-2025-5302

Denial of Service (DOS) in JSONReader in run-llama/llama_index

HIGH
8.6
CVSS Score
Published: August 25, 2025 at 03:03 PM UTC
Updated: June 17, 2026 at 09:47 AM UTC
1 product affected across 1 vendorLlamaindex

Using run-llama/llama_index by run-llama?

Get instant alerts when new vulnerabilities affect run-llama/llama_index - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.12.38
Affected range stops below 0.12.38, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.6HIGH@huntr_ai
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-674

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card