CVE-2025-4922

Nomad Vulnerable To Incorrect ACL Policy Lookup Attached To A Job

HIGH
8.1
CVSS Score
Published: June 11, 2025 at 01:24 PM UTC
Updated: June 17, 2026 at 09:34 AM UTC
1 product affected across 1 vendorNomad

Using Nomad by HashiCorp?

Get instant alerts when new vulnerabilities affect Nomad - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Nomad Community and Nomad Enterprise (“Nomad”) prefix-based ACL policy lookup can lead to incorrect rule application and shadowing. This vulnerability, identified as CVE-2025-4922, is fixed in Nomad Community Edition 1.10.2 and Nomad Enterprise 1.10.2, 1.9.10, and 1.8.14.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.10.0 ≤ v < 1.10.21.4.0 ≤ v < 1.10.21.4.0 ≤ v < 1.8.141.9.0 ≤ v < 1.9.101.4.0
Affected range stops below 1.10.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.1HIGHHashiCorp
Vector?

Quick Info

StatusANALYZED
CWE
CWE-266

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card