CVE-2025-48997

Multer vulnerable to Denial of Service via unhandled exception

HIGH
8.7
CVSS Score
Published: June 3, 2025 at 06:21 PM UTC
Updated: June 17, 2026 at 09:30 AM UTC
1 product affected across 1 vendorMulter

Using multer by expressjs?

Get instant alerts when new vulnerabilities affect multer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.7
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to `2.0.1` to receive a patch. No known workarounds are available.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.0.1
Affected range stops below 2.0.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.7HIGHGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-248

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card