CVE-2025-48386

Git allows a buffer overflow in 'wincred' credential helper

MEDIUM
6.3
CVSS Score
Published: July 8, 2025 at 06:23 PM UTC
Updated: June 17, 2026 at 09:29 AM UTC
1 product affected across 1 vendorGit

Using git by git?

Get instant alerts when new vulnerabilities affect git - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Git· Gitrubygems
60%
v < 2.43.7v < 2.44.4v < 2.45.4v < 2.46.4v < 2.47.3v < 2.48.2v < 2.49.1v < 2.50.1
Affected range stops below 2.43.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.44.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.45.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.46.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.47.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.48.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.49.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.50.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMGitHub_M
Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-120

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card