CVE-2025-48385

Git alllows arbitrary file writes via bundle-uri parameter injection

HIGH
8.6
CVSS Score
Published: July 8, 2025 at 06:23 PM UTC
Updated: June 17, 2026 at 09:29 AM UTC
1 product affected across 1 vendorGit

Using git by git?

Get instant alerts when new vulnerabilities affect git - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Git· Gitrubygems
60%
v < 2.43.7v < 2.44.4v < 2.45.4v < 2.46.4v < 2.47.3v < 2.48.2v < 2.49.1v < 2.50.1
Affected range stops below 2.43.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.44.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.45.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.46.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.47.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.48.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.49.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.50.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.6HIGHGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-73CWE-88

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card