CVE-2025-48370

auth-js Vulnerable to Insecure Path Routing from Malformed User Input

LOW
2.7
CVSS Score
Published: May 27, 2025 at 03:27 PM UTC
Updated: July 27, 2026 at 07:34 PM UTC
1 product affected across 1 vendorAuth Js

Using auth-js by supabase?

Get instant alerts when new vulnerabilities affect auth-js - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW2.7
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.69.1, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.69.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.70.0
Affected range stops below 2.70.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

2.7LOWGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-22CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card