CVE-2025-47939

TYPO3 CMS Vulnerable to Unrestricted File Upload in File Abstraction Layer

MEDIUM
5.4
CVSS Score
Published: May 20, 2025 at 02:00 PM UTC
Updated: June 17, 2026 at 09:28 AM UTC
1 product affected across 1 vendorTYPO3

Using typo3 by TYPO3?

Get instant alerts when new vulnerabilities affect typo3 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

TYPO3 is an open source, PHP based web content management system. By design, the file management module in TYPO3’s backend user interface has historically allowed the upload of any file type, with the exception of those that are directly executable in a web server context. This lack of restriction means it is possible to upload files that may be considered potentially harmful, such as executable binaries (e.g., `.exe` files), or files with inconsistent file extensions and MIME types (for example, a file incorrectly named with a `.png` extension but actually carrying the MIME type `application/zip`) starting in version 9.0.0 and prior to versions 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS. Although such files are not directly executable through the web server, their presence can introduce indirect risks. For example, third-party services such as antivirus scanners or malware detection systems might flag or block access to the website for end users if suspicious files are found. This could negatively affect the availability or reputation of the site. Users should update to TYPO3 version 9.5.51 ELTS, 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 10.4.50v < 11.5.44v < 12.4.31v < 13.4.12v < 9.5.5110.0.0 ≤ v < 10.4.5011.0.0 ≤ v < 11.5.4412.0.0 ≤ v < 12.4.3113.0.0 ≤ v < 13.4.129.0.0 ≤ v < 9.5.51
Affected range stops below 10.4.50, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.5.44, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.4.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.4.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.5.51, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.4MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-351CWE-434

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card