CVE-2025-4760

Authenticated Stored Cross-Site Scripting (XSS) in Multiple WSO2 Products via API Document Upload in Publisher

MEDIUM
4.8
CVSS Score
Published: September 23, 2025 at 02:55 PM UTC
Updated: October 18, 2026 at 09:10 PM UTC
5 products affected across 1 vendorAPI ManagerAPI Control PlaneTraffic Manager

Using WSO2 API Manager by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 API Manager - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

An authenticated stored cross-site scripting (XSS) vulnerability exists in multiple WSO2 products due to improper validation of user-supplied input during API document upload in the Publisher portal. A user with publisher privileges can upload a crafted API document containing malicious JavaScript, which is later rendered in the browser when accessed by other users. A successful attack could result in redirection to malicious websites, unauthorized UI modifications, or exfiltration of browser-accessible data. However, session-related sensitive cookies are protected by the httpOnly flag, preventing session hijacking.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 4.5.0.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.428, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.48, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.209, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.145, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.60, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.2.0 (unknown)
Affected range stops below 4.5.0.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.7, so it looks safe — our inference, not a vendor statement
6.7.206 ≤ v < 6.7.206.5596.7.210 ≤ v < 6.7.210.489.20.74 ≤ v < 9.20.74.3659.28.116 ≤ v < 9.28.116.3219.29.120 ≤ v < 9.29.120.1639.30.67 ≤ v < 9.30.67.809.31.86 ≤ v < 9.31.86.306.7.2066.7.2109.20.749.28.1169.29.1209.30.679.31.86
Affected range stops below 6.7.206.559, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.7.210.48, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.20.74.365, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.28.116.321, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.29.120.163, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.30.67.80, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.31.117 (unaffected)
Affected range stops below 9.31.86.30, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.8MEDIUMWSO2
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card