CVE-2025-46818

Redis: Authenticated users can execute LUA scripts as a different user

HIGH
7.3
CVSS Score
Published: October 3, 2025 at 06:38 PM UTC
Updated: October 19, 2026 at 05:10 PM UTC
1 product affected across 1 vendorRedis

Using redis by redis?

Get instant alerts when new vulnerabilities affect redis - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.3
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user. The problem exists in all versions of Redis with LUA scripting. This issue is fixed in version 8.2.2. A workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing LUA scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.2.207.0 ≤ v < 7.2.117.4.0 ≤ v < 7.4.68.0.0 ≤ v < 8.0.48.2.0 ≤ v < 8.2.2
Affected range stops below 8.2.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMThird Party Advisory
Source: cverecord
https://github.com/redis/redis/security/advisories/GHSA-qrv7-wcrx-q5jp
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/redis/redis/releases/tag/8.2.2

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card