CVE-2025-46731

Craft CMS Contains a Potential Remote Code Execution Vulnerability via Twig SSTI

HIGH
7.2
CVSS Score
Published: May 5, 2025 at 07:35 PM UTC
Updated: June 17, 2026 at 09:26 AM UTC
1 product affected across 1 vendorCraftcms

Using cms by craftcms?

Get instant alerts when new vulnerabilities affect cms - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 2%
SSVC
PoC

Description

Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.14.13v < 5.6.154.1.0 ≤ v < 4.14.135.1.0 ≤ v < 5.6.154.0.0 rc14.0.0 rc24.0.0 rc35.0.0 rc1
Affected range stops below 4.14.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.6.15, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-1336

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card