CVE-2025-46344

Auth0 NextJS SDK v4 Missing Session Invalidation

MEDIUM
4.9
CVSS Score
Published: April 29, 2025 at 08:43 PM UTC
Updated: June 17, 2026 at 09:26 AM UTC
1 product affected across 1 vendorNextjs AUTH0

Using nextjs-auth0 by auth0?

Get instant alerts when new vulnerabilities affect nextjs-auth0 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.9
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.5.1
Affected range stops below 4.5.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.9MEDIUMGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-613

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card