CVE-2025-3919

WordPress Comments Import & Export <= 2.4.3 - Missing Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting

MEDIUM
6.4
CVSS Score
Published: June 2, 2025 at 10:22 PM UTC
Updated: July 27, 2026 at 07:34 PM UTC
1 product affected across 1 vendorWordPress Comments Import and Export

Using WordPress Comments Import & Export by webtoffee?

Get instant alerts when new vulnerabilities affect WordPress Comments Import & Export - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.4
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The WordPress Comments Import & Export plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_settings function in all versions up to, and including, 2.4.3. Additionally, the plugin fails to properly sanitize and escape FTP settings parameters. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts on the plugin settings page that will execute whenever an administrative user accesses an injected page. The vulnerability was partially fixed in version 2.4.3 and fully fixed in version 2.4.4

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.4MEDIUMWordfence
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card