CVE-2025-3744

Nomad Vulnerable To Violation Of Mandatory Sentinel Policies in Nomad Job Submissions via Policy Override

HIGH
7.6
CVSS Score
Published: May 13, 2025 at 06:40 PM UTC
Updated: June 17, 2026 at 09:20 AM UTC
1 product affected across 1 vendorNomad

Using Nomad Enterprise by HashiCorp?

Get instant alerts when new vulnerabilities affect Nomad Enterprise - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.6
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Nomad Enterprise (“Nomad”) jobs using the policy override option are bypassing the mandatory sentinel policies. This vulnerability, identified as CVE-2025-3744, is fixed in Nomad Enterprise 1.10.1, 1.9.9, and 1.8.13.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.10.1v < 1.8.131.9.0 ≤ v < 1.9.91.10.01.10.0 beta11.10.0 rc1
Affected range stops below 1.10.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.8.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.6HIGHHashiCorp
Vector?

Quick Info

StatusANALYZED
CWE
CWE-266NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card