CVE-2025-3509

Pre-Receive Hook Remote Code Execution vulnerability was identified in GitHub Enterprise Server that allowing Privilege Escalation

HIGH
7.2
CVSS Score
Published: April 17, 2025 at 10:50 PM UTC
Updated: June 17, 2026 at 09:20 AM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

A Remote Code Execution (RCE) vulnerability was identified in GitHub Enterprise Server that allowed attackers to execute arbitrary code by exploiting the pre-receive hook functionality, potentially leading to privilege escalation and system compromise. The vulnerability involves using dynamically allocated ports that become temporarily available, such as during a hot patch upgrade. This means the vulnerability is only exploitable during specific operational conditions, which limits the attack window. Exploitation required either site administrator permissions to enable and configure pre-receive hooks or a user with permissions to modify repositories containing pre-receive hooks where this functionality was already enabled. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.17.1, 3.16.4, 3.15.8, 3.14.13, 3.13.16. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.13.1613.17.0 ≤ v < 13.17.13.13.0 ≤ v ≤ 3.13.153.14.0 ≤ v ≤ 3.14.123.14.0 ≤ v < 3.14.133.15.0 ≤ v ≤ 3.15.73.15.0 ≤ v < 3.15.83.16.0 ≤ v ≤ 3.16.33.16.0 ≤ v < 3.16.43.17.0 ≤ v < 3.17.113.17.03.13.03.14.03.15.03.16.0
Affected range stops below 13.17.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.13.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.14.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.15.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.16.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.17.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card