CVE-2025-32971

XWiki Solr script service doesn't take dropped programming right into account

LOW
3.8
CVSS Score
Published: April 30, 2025 at 02:54 PM UTC
Updated: June 17, 2026 at 09:12 AM UTC
1 product affected across 1 vendorXwiki

Using xwiki-platform by xwiki?

Get instant alerts when new vulnerabilities affect xwiki-platform - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.8
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

XWiki is a generic wiki platform. In versions starting from 4.5.1 to before 15.10.13, from 16.0.0-rc-1 to before 16.4.4, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the Solr script service doesn't take dropped programming rights into account. The Solr script service that is accessible in XWiki's scripting API normally requires programming rights to be called. Due to using the wrong API for checking rights, it doesn't take the fact into account that programming rights might have been dropped by calling `$xcontext.dropPermissions()`. If some code relies on this for the safety of executing Velocity code with the wrong author context, this could allow a user with script rights to either cause a high load by indexing documents or to temporarily remove documents from the search index. This issue has been patched in versions 15.10.13, 16.4.4, and 16.8.0-rc-1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.10.13v < 16.4.4v < 16.8.0-rc-116.0.0 ≤ v < 16.4.416.5.0 ≤ v < 16.8.04.5.1 ≤ v < 15.10.13
Affected range stops below 15.10.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.4.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.8.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.8.0-rc-1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.8LOWGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card