CVE-2025-32777

Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin

HIGH
8.2
CVSS Score
Published: April 30, 2025 at 06:27 PM UTC
Updated: June 17, 2026 at 09:12 AM UTC
1 product affected across 1 vendorVolcano

Using volcano by volcano-sh?

Get instant alerts when new vulnerabilities affect volcano - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.2
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Volcano is a Kubernetes-native batch scheduling system. Prior to versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2, attacker compromise of either the Elastic service or the extender plugin can cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. This issue has been patched in versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.10.2v < 1.11.0-network-topology-preview.3v < 1.11.2v < 1.12.0-alpha.2v < 1.9.1
Affected range stops below 1.10.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.11.0-network-topology-preview.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.11.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.12.0-alpha.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.2HIGHGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card