CVE-2025-3125

Authenticated Arbitrary File Upload in Multiple WSO2 Products via CarbonAppUploader Admin Service Leading to Remote Code Execution

HIGH
7.2
CVSS Score
Published: November 5, 2025 at 02:49 PM UTC
Updated: June 17, 2026 at 09:19 AM UTC
9 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Identity Server by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Identity Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

An arbitrary file upload vulnerability exists in multiple WSO2 products due to improper input validation in the CarbonAppUploader admin service endpoint. An authenticated attacker with appropriate privileges can upload a malicious file to a user-controlled location on the server, potentially leading to remote code execution (RCE). This functionality is restricted by default to admin users; therefore, successful exploitation requires valid credentials with administrative permissions.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.24.6.0 ≤ v < 4.6.0.34.5.04.6.0
Affected range stops below 4.5.0.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
3.2.0 ≤ v < 3.2.0.4213.2.1 ≤ v < 3.2.1.414.0.0 ≤ v < 4.0.0.3424.1.0 ≤ v < 4.1.0.2034.2.0 ≤ v < 4.2.0.1424.3.0 ≤ v < 4.3.0.554.4.0 ≤ v < 4.4.0.194.5.0 ≤ v < 4.5.0.24.6.0 ≤ v < 4.6.0.33.2.03.2.14.0.04.1.04.2.04.3.04.4.04.5.04.6.0
Affected range stops below 3.2.0.421, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.342, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.203, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.142, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.55, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.2.0 (unknown)
6.6.0 ≤ v < 6.6.0.2176.6.0
Affected range stops below 6.6.0.217, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
5.10.0 ≤ v < 5.10.0.3605.11.0 ≤ v < 5.11.0.3996.0.0 ≤ v < 6.0.0.2356.1.0 ≤ v < 6.1.0.2307.0.0 ≤ v < 7.0.0.1017.1.0 ≤ v < 7.1.0.325.10.05.11.06.0.06.1.07.0.07.1.0
Affected range stops below 5.10.0.360, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.399, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.235, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.230, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.101, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.32, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.3535.10.0
Affected range stops below 5.10.0.353, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.4022.0.0
Affected range stops below 2.0.0.402, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
4.5.0 ≤ v < 4.5.0.24.6.0 ≤ v < 4.6.0.34.5.04.6.0
Affected range stops below 4.5.0.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
4.5.0 ≤ v < 4.5.0.24.6.0 ≤ v < 4.6.0.34.5.04.6.0
Affected range stops below 4.5.0.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
4.10.13 ≤ v < 4.10.13.14.7.19 ≤ v < 4.7.19.74.7.32 ≤ v < 4.7.32.54.7.35 ≤ v < 4.7.35.84.7.39 ≤ v < 4.7.39.14.7.49 ≤ v < 4.7.49.44.7.52 ≤ v < 4.7.52.14.10.134.7.194.7.324.7.354.7.394.7.494.7.52
Affected range stops below 4.10.13.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.10.24 (unaffected)
Affected range stops below 4.7.19.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.32.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.35.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.39.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.49.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.52.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.9.12 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-434

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card