CVE-2025-31129

jooby-pac4j: deserialization of untrusted data

HIGH
8.8
CVSS Score
Published: March 31, 2025 at 07:10 PM UTC
Updated: June 17, 2026 at 09:09 AM UTC
1 product affected across 1 vendorJooby

Using jooby by jooby-project?

Get instant alerts when new vulnerabilities affect jooby - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Jooby is a web framework for Java and Kotlin. The pac4j io.jooby.internal.pac4j.SessionStoreImpl#get module deserializes untrusted data. This vulnerability is fixed in 2.17.0 (2.x) and 3.7.0 (3.x).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.17.0v < 3.7.0
Affected range stops below 2.17.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.7.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card