CVE-2025-31125

Vite has a `server.fs.deny` bypassed for `inline` and `raw` with `?import` query

HIGH
7.5
CVSS Score
Published: March 31, 2025 at 05:06 PM UTC
Updated: June 17, 2026 at 09:09 AM UTC
1 product affected across 1 vendorVite

Using vite by vitejs?

Get instant alerts when new vulnerabilities affect vite - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploitation
CISA KEV
Exploit prediction
EPSS 75%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score74.9%

EPSS (Exploit Prediction Scoring System) estimates a 74.9% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Vite Vitejs contains an improper access control vulnerability that exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected.

Required Action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Jan 22, 2026
Remediation Due
Feb 12, 2026
261 days overdue

Description

Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. This vulnerability is fixed in 6.2.4, 6.1.3, 6.0.13, 5.4.16, and 4.5.11.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.5.11v < 5.4.16v < 6.0.13v < 6.1.3v < 6.2.45.0.0 ≤ v < 5.4.166.0.0 ≤ v < 6.0.136.1.0 ≤ v < 6.1.36.2.0 ≤ v < 6.2.4
Affected range stops below 4.5.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-200CWE-284NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card