CVE-2025-30168

Parse Server has an OAuth login vulnerability

MEDIUM
6.9
CVSS Score
Published: March 21, 2025 at 02:54 PM UTC
Updated: June 17, 2026 at 09:08 AM UTC
1 product affected across 1 vendorParse Server

Using parse-server by parse-community?

Get instant alerts when new vulnerabilities affect parse-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.9
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 7.5.2 and 8.0.2, the 3rd party authentication handling of Parse Server allows the authentication credentials of some specific authentication providers to be used across multiple Parse Server apps. For example, if a user signed up using the same authentication provider in two unrelated Parse Server apps, the credentials stored by one app can be used to authenticate the same user in the other app. Note that this only affects Parse Server apps that specifically use an affected 3rd party authentication provider for user authentication, for example by setting the Parse Server option auth to configure a Parse Server authentication adapter. The fix of this vulnerability requires to upgrade Parse Server to a version that includes the bug fix, as well as upgrade the client app to send a secure payload, which is different from the previous insecure payload. This vulnerability is fixed in 7.5.2 and 8.0.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 7.5.2v < 8.0.2
Affected range stops below 7.5.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.9MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card