CVE-2025-2817

Privilege escalation in Thunderbird Updater

HIGH
8.8
CVSS Score
Published: April 29, 2025 at 01:13 PM UTC
Updated: October 5, 2026 at 03:10 PM UTC
2 products affected across 1 vendorFirefoxThunderbird

Using Firefox by Mozilla?

Get instant alerts when new vulnerabilities affect Firefox - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Thunderbird's update mechanism allowed a medium-integrity user process to interfere with the SYSTEM-level updater by manipulating the file-locking behavior. By injecting code into the user-privileged process, an attacker could bypass intended access controls, allowing SYSTEM-level file operations on paths controlled by a non-privileged user and enabling privilege escalation. This vulnerability affects Firefox < 138, Firefox ESR < 128.10, Firefox ESR < 115.23, Thunderbird < 138, and Thunderbird < 128.10.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 115.23.0v < 138.0116.0 ≤ v < 128.10.0
Vendor states this is fixed in 115.23 (unaffected)
Affected range stops below 115.23.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 128.10 (unaffected)
Affected range stops below 128.10.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 138 (unaffected)
Affected range stops below 138.0, so it looks safe — our inference, not a vendor statement
v < 128.10.0129.0 ≤ v < 138.0
Vendor states this is fixed in 128.10 (unaffected)
Affected range stops below 128.10.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 138 (unaffected)
Affected range stops below 138.0, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card