CVE-2025-27867

Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin

MEDIUM
5.6
CVSS Score
Published: March 12, 2025 at 03:51 PM UTC
Updated: June 17, 2026 at 09:04 AM UTC
1 product affected across 1 vendorFelix HTTP Webconsole Plugin

Using Apache Felix HTTP Webconsole Plugin by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Felix HTTP Webconsole Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.6
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.0.0 ≤ v < 1.2.21.x ≤ v ≤ 1.2.01.x
Affected range stops below 1.2.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2025/03/12/3

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.6MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card