CVE-2025-23209

Potential RCE with a compromised security key in craft/cms

HIGH
8.1
CVSS Score
Published: January 18, 2025 at 12:32 AM UTC
Updated: June 17, 2026 at 08:52 AM UTC
1 product affected across 1 vendorCraftcms

Using cms by craftcms?

Get instant alerts when new vulnerabilities affect cms - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploitation
CISA KEV
Exploit prediction
EPSS 22%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score21.6%

EPSS (Exploit Prediction Scoring System) estimates a 21.6% chance this CVE is exploited in the wild within the next 30 days — higher than 98% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Craft CMS contains a code injection vulnerability caused by improper validation of the database backup path, ultimately enabling remote code execution.

Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Feb 20, 2025
Remediation Due
Mar 13, 2025
592 days overdue

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.13.8v < 5.5.54.0.0 < v < 4.13.85.0.0 < v < 5.5.84.0.04.0.0 rc14.0.0 rc24.0.0 rc35.0.05.0.0 rc1
Affected range stops below 4.13.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.1HIGHGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card