CVE-2025-23047

Cilium vulnerable to information leakage via insecure default Hubble UI CORS header

MEDIUM
6.5
CVSS Score
Published: January 22, 2025 at 05:20 PM UTC
Updated: June 17, 2026 at 08:51 AM UTC
1 product affected across 1 vendorCilium

Using cilium by cilium?

Get instant alerts when new vulnerabilities affect cilium - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An insecure default `Access-Control-Allow-Origin` header value could lead to sensitive data exposure for users of Cilium versions 1.14.0 through 1.14.7, 1.15.0 through 1.15.11, and 1.16.0 through 1.16.4 who deploy Hubble UI using either Cilium CLI or via the Cilium Helm chart. A user with access to a Hubble UI instance affected by this issue could leak configuration details about the Kubernetes cluster which Hubble UI is monitoring, including node names, IP addresses, and other metadata about workloads and the cluster networking configuration. In order for this vulnerability to be exploited, a victim would have to first visit a malicious page. This issue is fixed in Cilium v1.14.18, v1.15.12, and v1.16.5. As a workaround, users who deploy Hubble UI using the Cilium Helm chart directly can remove the CORS headers from the Helm template as shown in the patch from commit a3489f190ba6e87b5336ee685fb6c80b1270d06d.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.14.18v < 1.15.12v < 1.16.51.14.0 ≤ v < 1.14.191.15.0 ≤ v < 1.15.131.16.0 ≤ v < 1.16.6
Affected range stops below 1.14.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.14.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.15.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.15.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.16.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.16.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card