CVE-2025-22166

HIGH
7.5
CVSS Score
Published: October 21, 2025 at 04:00 PM UTC
Updated: October 8, 2026 at 11:10 AM UTC
2 products affected across 1 vendorConfluence ServerConfluence Data Center

Using Confluence Data Center by Atlassian?

Get instant alerts when new vulnerabilities affect Confluence Data Center - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

This High severity DoS (Denial of Service) vulnerability was introduced in version 2.0 of Confluence Data Center. This DoS (Denial of Service) vulnerability, with a CVSS Score of 8.3, allows an attacker to cause a resource to be unavailable for its intended users by temporarily or indefinitely disrupting services of a host connected to a network. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.25 Confluence Data Center and Server 9.2: Upgrade to a release greater than or equal to 9.2.7 Confluence Data Center and Server 10.0: Upgrade to a release greater than or equal to 10.0.2 See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Atlassian (Internal) program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0.0 ≤ v < 10.0.28.5.0 ≤ v < 8.5.259.2.0 ≤ v < 9.2.7*7.19.16 to 7.19.308.5.138.5.228.5.238.5.248.5.3 to 8.5.248.6.1 to 8.6.28.7.1 to 8.7.28.8.0 to 8.8.18.9.0 to 8.9.89.0.1 to 9.0.39.1.0 to 9.1.19.2.0 to 9.2.69.2.29.2.39.2.49.2.59.2.69.3.1 to 9.3.29.4.0 to 9.4.19.4.19.5.1 to 9.5.4
Affected range stops below 10.0.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 10.0.2 to 10.0.3 (unaffected)
Affected range stops below 8.5.25, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8.5.25 to 8.5.27 (unaffected)
Affected range stops below 9.2.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.2.7 to 9.2.9 (unaffected)
10.0.0 ≤ v < 10.0.28.5.0 ≤ v < 8.5.259.2.0 ≤ v < 9.2.7*
Affected range stops below 10.0.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.5.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.2.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-405

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card