CVE-2025-21804

PCI: rcar-ep: Fix incorrect variable used when calling devm_request_mem_region()

MEDIUM
5.5
CVSS Score
Published: February 27, 2025 at 08:00 PM UTC
Updated: August 5, 2026 at 12:44 PM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.2%

Description

In the Linux kernel, the following vulnerability has been resolved: PCI: rcar-ep: Fix incorrect variable used when calling devm_request_mem_region() The rcar_pcie_parse_outbound_ranges() uses the devm_request_mem_region() macro to request a needed resource. A string variable that lives on the stack is then used to store a dynamically computed resource name, which is then passed on as one of the macro arguments. This can lead to undefined behavior. Depending on the current contents of the memory, the manifestations of errors may vary. One possible output may be as follows: $ cat /proc/iomem 30000000-37ffffff : 38000000-3fffffff : Sometimes, garbage may appear after the colon. In very rare cases, if no NULL-terminator is found in memory, the system might crash because the string iterator will overrun which can lead to access of unmapped memory above the stack. Thus, fix this by replacing outbound_name with the name of the previously requested resource. With the changes applied, the output will be as follows: $ cat /proc/iomem 30000000-37ffffff : memory2 38000000-3fffffff : memory3 [kwilczynski: commit log]

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

5.11 ≤ v < 5.15.1795.16 ≤ v < 6.1.1295.8 ≤ v < 5.10.2355.8 ≤ v < 5.15.1795.8 ≤ v < 6.1.1295.8 ≤ v < 6.12.135.8 ≤ v < 6.13.25.8 ≤ v < 6.145.8 ≤ v < 6.6.766.13 ≤ v < 6.13.26.2 ≤ v < 6.6.766.7 ≤ v < 6.12.132a6d0d63d99956a66f6605832f11755d74a419515.8
Vendor states this is fixed in 24576899c49509c0d533bcf569139f691d8f7af7 (fixed)
Vendor states this is fixed in 2c54b9fca1755e80a343ccfde0652dc5ea4744b2 (fixed)
Vendor states this is fixed in 2d2da5a4c1b4509f6f7e5a8db015cd420144beb4 (fixed)
Vendor states this is fixed in 44708208c2a4b828a57a2abe7799c9d3962e7eaa (fixed)
Vendor states this is fixed in 6987e021b64cbb49981d140bb72d9d1466f191c4 (fixed)
Vendor states this is fixed in 7a47e14c5fb0b6dba7073be7b0119fb8fe864e01 (fixed)
Vendor states this is fixed in 9ff46b0bfeb6e0724a4ace015aa7a0b887cdb7c1 (fixed)
Vendor states this is fixed in 5.10.235 (unaffected)
Vendor states this is fixed in 5.15.179 (unaffected)
Vendor states this is fixed in 5.8 (unaffected)
Vendor states this is fixed in 6.1.129 (unaffected)
Vendor states this is fixed in 6.12.13 (unaffected)
Vendor states this is fixed in 6.13.2 (unaffected)
Vendor states this is fixed in 6.14 (unaffected)
Vendor states this is fixed in 6.6.76 (unaffected)

References (9)

Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/24576899c49509c0d533bcf569139f691d8f7af7
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/2c54b9fca1755e80a343ccfde0652dc5ea4744b2
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/2d2da5a4c1b4509f6f7e5a8db015cd420144beb4
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/44708208c2a4b828a57a2abe7799c9d3962e7eaa
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/6987e021b64cbb49981d140bb72d9d1466f191c4
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/7a47e14c5fb0b6dba7073be7b0119fb8fe864e01
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/9ff46b0bfeb6e0724a4ace015aa7a0b887cdb7c1
Source: af854a3a-2127-422b-91ae-364da2661108
https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-476

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card