CVE-2025-21600

Junos OS and Junos OS Evolved: With certain BGP options enabled, receipt of specifically malformed BGP update causes RPD crash

MEDIUM
6.5
CVSS Score
Published: January 9, 2025 at 04:49 PM UTC
Updated: June 17, 2026 at 08:43 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

An Out-of-Bounds Read vulnerability in the routing protocol daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated, logically adjacent BGP peer sending a specifically malformed BGP packet to cause rpd to crash and restart, resulting in a Denial of Service (DoS). Continued receipt and processing of this packet will create a sustained Denial of Service (DoS) condition. This issue only affects systems configured in either of two ways: * systems with BGP traceoptions enabled * systems with BGP family traffic-engineering (BGP-LS) configured and can be exploited from a directly connected and configured BGP peer. This issue affects iBGP and eBGP with any address family configured, and both IPv4 and IPv6 are affected by this vulnerability. This issue affects: Junos OS: * from 21.4 before 21.4R3-S9,  * from 22.2 before 22.2R3-S5,  * from 22.3 before 22.3R3-S4,  * from 22.4 before 22.4R3-S5,  * from 23.2 before 23.2R2-S3,  * from 23.4 before 23.4R2-S3,  * from 24.2 before 24.2R1-S2, 24.2R2; Junos OS Evolved: * from 21.4-EVO before 21.4R3-S9-EVO,  * from 22.2-EVO before 22.2R3-S5-EVO,  * from 22.3-EVO before 22.3R3-S4-EVO,  * from 22.4-EVO before 22.4R3-S5-EVO,  * from 23.2-EVO before 23.2R2-S3-EVO,  * from 23.4-EVO before 23.4R2-S2-EVO,  * from 24.2-EVO before 24.2R1-S2-EVO, 24.2R2-EVO. This issue does not affect versions of Junos OS prior to 21.3R1. This issue does not affect versions of Junos OS Evolved prior to 21.3R1-EVO. This is a similar, but different vulnerability than the issue reported as CVE-2024-39516.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 21.3R1 (unaffected)
Affected range stops below 21.4R3-S9, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R3-S5, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.3R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.4R3-S5, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.2R2-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.4R2-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.2R1-S2, 24.2R2, so it looks safe — our inference, not a vendor statement
21.4-EVO ≤ v < 21.4R3-S9-EVO22.2-EVO ≤ v < 22.2R3-S5-EVO22.3-EVO ≤ v < 22.3R3-S4-EVO22.4-EVO ≤ v < 22.4R3-S5-EVO23.2-EVO ≤ v < 23.2R2-S3-EVO23.4-EVO ≤ v < 23.4R2-S2-EVO24.2-EVO ≤ v < 24.2R1-S2-EVO, 24.2R2-EVO21.4-EVO22.2-EVO22.3-EVO22.4-EVO23.2-EVO23.4-EVO24.2-EVO
Vendor states this is fixed in 21.3R1-EVO (unaffected)
Affected range stops below 21.4R3-S9-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R3-S5-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.3R3-S4-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.4R3-S5-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.2R2-S3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.4R2-S2-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.2R1-S2-EVO, 24.2R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMjuniper
Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-125

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card