CVE-2025-15467

Stack buffer overflow in CMS (Auth)EnvelopedData parsing

HIGH
8.8
CVSS Score
Published: January 27, 2026 at 04:01 PM UTC
Updated: October 15, 2026 at 02:17 AM UTC
104 products affected across 3 vendorsOpenSSLOpenShift Container PlatformSINEC NMS

Using OpenSSL by OpenSSL?

Get instant alerts when new vulnerabilities affect OpenSSL - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 75%
SSVC
PoC

Description

Issue summary: Parsing CMS AuthEnvelopedData message with maliciously crafted AEAD parameters can trigger a stack buffer overflow. Impact summary: A stack buffer overflow may lead to a crash, causing Denial of Service, or potentially remote code execution. When parsing CMS AuthEnvelopedData structures that use AEAD ciphers such as AES-GCM, the IV (Initialization Vector) encoded in the ASN.1 parameters is copied into a fixed-size stack buffer without verifying that its length fits the destination. An attacker can supply a crafted CMS message with an oversized IV, causing a stack-based out-of-bounds write before any authentication or tag verification occurs. Applications and services that parse untrusted CMS or PKCS#7 content using AEAD ciphers (e.g., S/MIME AuthEnvelopedData with AES-GCM) are vulnerable. Because the overflow occurs prior to authentication, no valid key material is required to trigger it. While exploitability to remote code execution depends on platform and toolchain mitigations, the stack-based write primitive represents a severe risk. The FIPS modules in 3.6, 3.5, 3.4, 3.3 and 3.0 are not affected by this issue, as the CMS implementation is outside the OpenSSL FIPS module boundary. OpenSSL 3.6, 3.5, 3.4, 3.3 and 3.0 are vulnerable to this issue. OpenSSL 1.1.1 and 1.0.2 are not affected by this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions3.0.0 ≤ v < 3.0.193.1.0 ≤ v < 3.3.63.4.0 ≤ v < 3.4.43.5.0 ≤ v < 3.5.53.6.0 ≤ v < 3.6.13.0.03.3.03.4.03.5.03.6.0
Affected range stops below 3.0.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.3.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.4.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.5.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.6.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.19.9.6.202602112047-0 (unaffected)
Vendor states this is fixed in 4.20.9.6.202602050328-0 (unaffected)
Vendor states this is fixed in 413.92.202602240113-0 (unaffected)
Vendor states this is fixed in 414.92.202602171627-0 (unaffected)
Vendor states this is fixed in 415.92.202603101737-0 (unaffected)
Vendor states this is fixed in 416.94.202602101357-0 (unaffected)
Vendor states this is fixed in 417.94.202602090846-0 (unaffected)
Vendor states this is fixed in 418.94.202602022246-0 (unaffected)
v < V1.8.0
Affected range stops below V1.8.0, so it looks safe — our inference, not a vendor statement
v < V3.3.2
Affected range stops below V3.3.2, so it looks safe — our inference, not a vendor statement
v < V9.0 QU1
Affected range stops below V9.0 QU1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCAutomatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-787CWE-120

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card