CVE-2025-14795

Stop Spammers Classic <= 2026.1 - Cross-Site Request Forgery via Email Allowlist

MEDIUM
4.3
CVSS Score
Published: January 28, 2026 at 01:26 PM UTC
Updated: June 17, 2026 at 08:36 AM UTC
1 product affected across 1 vendorStop Spammers Classic

Using Stop Spammers Classic by webguyio?

Get instant alerts when new vulnerabilities affect Stop Spammers Classic - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The vulnerability was partially patched in version 2026.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 2026.1

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMWordfence
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card