CVE-2025-14779

Improper Access Control via Secret Type Management API in WSO2 Identity Server

LOW
3.8
CVSS Score
Published: August 6, 2026 at 07:33 AM UTC
Updated: September 29, 2026 at 07:10 PM UTC
3 products affected across 1 vendorIdentity ServerCarbon Identity API Server Secret MgtCarbon Identity API Server Secret Mgt Common

Using WSO2 Identity Server by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Identity Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.8
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The Secret Type Management REST API does not correctly isolate access controls when deleting a secret type. The on-delete cascade logic, when triggered, fails to enforce organizational boundaries, leading to the removal of secrets associated with that type across all organizations. Exploitation of this vulnerability can result in the unintended deletion of secrets across the entire deployment, potentially causing configuration failures, service interruptions, and a denial-of-service condition. This vulnerability requires delete permissions for the Secret Type Management REST API, which are by default only granted to administrators.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

6.0.0 ≤ v < 6.0.0.2616.1.0 ≤ v < 6.1.0.2627.1.0 ≤ v < 7.1.0.466.0.06.1.07.1.0
Affected range stops below 6.0.0.261, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.262, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.46, so it looks safe — our inference, not a vendor statement
1.2.23 ≤ v < 1.2.23.111.2.3 ≤ v < 1.2.3.71.3.83 ≤ v < 1.3.83.161.2.231.2.31.3.83
Affected range stops below 1.2.23.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.2.3.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.3.83.16, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.8.521 (unaffected)
1.2.23 ≤ v < 1.2.23.111.2.3 ≤ v < 1.2.3.71.3.83 ≤ v < 1.3.83.161.2.231.2.31.3.83
Affected range stops below 1.2.23.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.2.3.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.3.83.16, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.8.521 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.8LOWWSO2
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-281

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card