CVE-2025-1474

Weak Password Requirements in mlflow/mlflow

MEDIUM
5.5
CVSS Score
Published: March 20, 2025 at 10:10 AM UTC
Updated: June 17, 2026 at 08:39 AM UTC
2 products affected across 2 vendorsMlflowMLflow

Using mlflow/mlflow by mlflow?

Get instant alerts when new vulnerabilities affect mlflow/mlflow - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

In mlflow/mlflow version 2.18, an admin is able to create a new user account without setting a password. This vulnerability could lead to security risks, as accounts without passwords may be susceptible to unauthorized access. Additionally, this issue violates best practices for secure user account management. The issue is fixed in version 2.19.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.19.0
Affected range stops below 2.19.0, so it looks safe — our inference, not a vendor statement
v < 2.19.0
Affected range stops below 2.19.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-521

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card