CVE-2025-13909

Information Disclosure via Multi-Tenant Authentication Flows in WSO2 Identity Server Allows Cross-Tenant PII Exposure

MEDIUM
4.3
CVSS Score
Published: August 6, 2026 at 07:33 AM UTC
Updated: September 29, 2026 at 02:10 PM UTC
5 products affected across 1 vendorIdentity ServerCarbon Identity Application Authentication FrameworkEmail OTP Authenticator

Using WSO2 Identity Server by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Identity Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The system accepts authentication requests without sufficient validation to enforce tenant isolation when using Email OTP, SMS OTP, or Magic Link as first-factor authenticators. This failure to adequately separate user data between tenants can lead to the exposure of personally identifiable information. Successful exploitation allows an attacker to disclose personally identifiable information of users in different tenants, resulting in privacy violations and potential regulatory non-compliance. This may include unauthorized access to user details such as mobile numbers.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.0.0 ≤ v < 7.0.0.1347.1.0 ≤ v < 7.1.0.427.0.07.1.0
Affected range stops below 7.0.0.134, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.42, so it looks safe — our inference, not a vendor statement
1.0.10 ≤ v < 1.0.10.11.0.5 ≤ v < 1.0.5.41.0.101.0.5
Affected range stops below 1.0.10.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.0.24 (unaffected)
Affected range stops below 1.0.5.4, so it looks safe — our inference, not a vendor statement
7.0.78 ≤ v < 7.0.78.1627.8.23 ≤ v < 7.8.23.667.0.787.8.23
Affected range stops below 7.0.78.162, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.8.23.66, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.8.550 (unaffected)
1.1.22 ≤ v < 1.1.22.61.1.31 ≤ v < 1.1.31.31.1.221.1.31
Affected range stops below 1.1.22.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.1.31.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.1.45 (unaffected)
1.0.30 ≤ v < 1.0.30.41.0.30
Affected range stops below 1.0.30.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.0.51 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMWSO2
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-200CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card