CVE-2025-13736

Username Enumeration via Login Interface in Multiple WSO2 Products Allows User Account Discovery

LOW
3.7
CVSS Score
Published: August 6, 2026 at 07:33 AM UTC
Updated: September 29, 2026 at 02:10 PM UTC
5 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Identity Server as Key Manager by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Identity Server as Key Manager - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.7
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

When Multi-Attribute Login is enabled, the login interface fails to consistently mask the existence of user accounts. For valid users, the server resolves and displays their canonical username, while for non-existent users, it echoes the original input. This occurs regardless of the validate_username configuration. The discovery of valid usernames can increase the risk of brute force attacks, social engineering attacks, and targeted information leakage. Attackers can leverage this information to craft more effective phishing campaigns or social engineering tactics to compromise user accounts or extract sensitive data.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.1.0 ≤ v < 3.1.0.3513.2.0 ≤ v < 3.2.0.4554.0.0 ≤ v < 4.0.0.3753.1.03.2.04.0.0
Affected range stops below 3.1.0.351, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.455, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.375, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
5.10.0 ≤ v < 5.10.0.3805.11.0 ≤ v < 5.11.0.4276.0.0 ≤ v < 6.0.0.2546.1.0 ≤ v < 6.1.0.2557.0.0 ≤ v < 7.0.0.1327.1.0 ≤ v < 7.1.0.407.2.0 ≤ v < 7.2.0.25.10.05.11.06.0.06.1.07.0.07.1.07.2.0
Affected range stops below 5.10.0.380, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.427, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.254, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.255, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.132, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.40, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.2.0.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.3715.10.0
Affected range stops below 5.10.0.371, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.4002.0.0
Affected range stops below 2.0.0.400, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.4202.0.0
Affected range stops below 2.0.0.420, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.7LOWWSO2
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-203

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card