CVE-2025-13590

Authenticated arbitrary file upload via a System REST API requiring administrator permission.

HIGH
7.2
CVSS Score
Published: February 19, 2026 at 10:05 AM UTC
Updated: October 28, 2026 at 08:06 AM UTC
5 products affected across 1 vendorAPI ManagerAPI Control PlaneTraffic Manager

Using WSO2 API Manager by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 API Manager - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

A malicious actor with administrative privileges can upload an arbitrary file to a user-controlled location within the deployment via a system REST API. Successful uploads may lead to remote code execution. By leveraging the vulnerability, a malicious actor may perform Remote Code Execution by uploading a specially crafted payload.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 4.5.0.39, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.5.0 (unknown)
Vendor states this is fixed in 4.2.0 (unaffected)
Affected range stops below 4.2.0.179, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.91, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.55, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.38, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.37, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.5.0 (unknown)
Affected range stops below 4.5.0.37, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.5.0 (unknown)
Affected range stops below 9.28.116.391, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.29.120.210, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.30.67.133, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.31.86.100, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.32.147.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.32.167 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfoCWE-434

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card