CVE-2025-11578

Pre-Receive Hook Path Collision Vulnerability in GitHub Enterprise Server Allowing Privilege Escalation

HIGH
7.2
CVSS Score
Published: November 10, 2025 at 10:44 PM UTC
Updated: October 7, 2026 at 09:10 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

A privilege escalation vulnerability was identified in GitHub Enterprise Server that allowed an authenticated Enterprise admin to gain root SSH access to the appliance by exploiting a symlink escape in pre-receive hook environments. By crafting a malicious repository and environment, an attacker could replace system binaries during hook cleanup and execute a payload that adds their own SSH key to the root user’s authorized keys—thereby granting themselves root SSH access to the server. To exploit this vulnerability, the attacker needed to have enterprise admin privileges. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.19, and was fixed in versions 3.14.19, 3.15.14, 3.16.10, 3.17.7 and 3.18.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.14 ≤ v ≤ 3.14.193.14.0 ≤ v < 3.14.203.15 ≤ v ≤ 3.15.143.15.0 ≤ v < 3.15.153.16 ≤ v ≤ 3.16.103.16.0 ≤ v < 3.16.113.17 ≤ v ≤ 3.17.73.17.0 ≤ v < 3.17.83.18 ≤ v ≤ 3.18.13.18.0 ≤ v < 3.18.23.143.153.163.173.18
Affected range stops below 3.14.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.15.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.16.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.17.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.2, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-59

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card