CVE-2025-11093

Arbitrary Code Execution with higher privileged users in Multiple WSO2 Products via Script Mediator Engines (GraalJS and NashornJS)

HIGH
7.2
CVSS Score
Published: November 5, 2025 at 06:31 PM UTC
Updated: June 17, 2026 at 08:29 AM UTC
11 products affected across 1 vendorAPI ManagerAPI Control PlaneEnterprise Integrator

Using WSO2 Micro Integrator by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Micro Integrator - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

An arbitrary code execution vulnerability exists in multiple WSO2 products due to insufficient restrictions in the GraalJS and NashornJS Script Mediator engines. Authenticated users with elevated privileges can execute arbitrary code within the integration runtime environment. By default, access to these scripting engines is limited to administrators in WSO2 Micro Integrator and WSO2 Enterprise Integrator, while in WSO2 API Manager, access extends to both administrators and API creators. This may allow trusted-but-privileged users to perform unauthorized actions or compromise the execution environment.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.294.5.0
Affected range stops below 4.5.0.29, so it looks safe — our inference, not a vendor statement
3.1.0 ≤ v < 3.1.0.3453.2.0 ≤ v < 3.2.0.4463.2.1 ≤ v < 3.2.1.664.0.0 ≤ v < 4.0.0.3664.1.0 ≤ v < 4.1.0.2284.2.0 ≤ v < 4.2.0.1694.3.0 ≤ v < 4.3.0.814.4.0 ≤ v < 4.4.0.454.5.0 ≤ v < 4.5.0.283.1.03.2.03.2.14.0.04.1.04.2.04.3.04.4.04.5.0
Affected range stops below 3.1.0.345, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.446, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.66, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.366, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.228, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.169, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.81, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.45, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.28, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
6.6.0 ≤ v < 6.6.0.2246.6.0
Affected range stops below 6.6.0.224, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
4.0.0 ≤ v < 4.0.0.1454.1.0 ≤ v < 4.1.0.1474.2.0 ≤ v < 4.2.0.1414.3.0 ≤ v < 4.3.0.424.4.0 ≤ v < 4.4.0.274.0.04.1.04.2.04.3.04.4.0
Affected range stops below 4.0.0.145, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.147, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.141, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.42, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.27, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.0.0 (unknown)
4.5.0 ≤ v < 4.5.0.274.5.0
Affected range stops below 4.5.0.27, so it looks safe — our inference, not a vendor statement
4.5.0 ≤ v < 4.5.0.274.5.0
Affected range stops below 4.5.0.27, so it looks safe — our inference, not a vendor statement
5.10.0 ≤ v < 5.10.0.3655.10.0
Affected range stops below 5.10.0.365, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.3942.0.0
Affected range stops below 2.0.0.394, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.4142.0.0
Affected range stops below 2.0.0.414, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.1.7.wso2v143 ≤ v < 2.1.7.wso2v143_1212.1.7.wso2v183 ≤ v < 2.1.7.wso2v183_722.1.7.wso2v227 ≤ v < 2.1.7.wso2v227_992.1.7.wso2v271 ≤ v < 2.1.7.wso2v271_882.1.7.wso2v319 ≤ v < 2.1.7.wso2v319_134.0.0.wso2v105 ≤ v < 4.0.0.wso2v105_134.0.0.wso2v119 ≤ v < 4.0.0.wso2v119_274.0.0.wso2v131 ≤ v < 4.0.0.wso2v131_54.0.0.wso2v20 ≤ v < 4.0.0.wso2v20_934.0.0.wso2v215 ≤ v < 4.0.0.wso2v215_264.0.0.wso2v218 ≤ v < 4.0.0.wso2v218_12.1.7.wso2v1432.1.7.wso2v1832.1.7.wso2v2272.1.7.wso2v2712.1.7.wso2v3194.0.0.wso2v1054.0.0.wso2v1194.0.0.wso2v1314.0.0.wso2v204.0.0.wso2v2154.0.0.wso2v218
Affected range stops below 2.1.7.wso2v143_121, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v183_72, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v227_99, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v271_88, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v319_13, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.0.0-wso2v254 (unaffected)
Affected range stops below 4.0.0.wso2v105_13, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v119_27, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v131_5, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v20_93, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v215_26, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v218_1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card