CVE-2025-10908

Account Lock Bypass via Magic Link or Pass Key Authentication in WSO2 Identity Server Allows Unauthorized Access

HIGH
7.3
CVSS Score
Published: May 11, 2026 at 09:01 AM UTC
Updated: October 14, 2026 at 01:10 PM UTC
2 products affected across 1 vendorIdentity ServerCarbon Magiclink Authenticator

Using WSO2 Identity Server by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Identity Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Due to a lack of user account state validation during authentication, locked user accounts can be successfully authenticated using Magic Link or Pass Key methods. This bypasses the intended security control that should prevent access to accounts that have been locked. This vulnerability may allow unauthorized access to applications and sensitive data associated with accounts that should have been restricted via the account lock mechanism. It also undermines the effectiveness of the account lock mechanism intended to prevent further login attempts.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions6.0.0 ≤ v < 6.0.0.2496.1.0 ≤ v < 6.1.0.2487.0.0 ≤ v < 7.0.0.1247.1.0 ≤ v < 7.1.0.316.0.06.1.07.0.07.1.0
Affected range stops below 6.0.0.249, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.248, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.124, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.31, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.0.0 (unknown)
1.1.0 ≤ v < 1.1.0.11.1.22 ≤ v < 1.1.22.51.1.31 ≤ v < 1.1.31.21.1.5 ≤ v < 1.1.5.21.1.01.1.221.1.311.1.5
Affected range stops below 1.1.0.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.1.22.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.1.31.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.1.43 (unaffected)
Affected range stops below 1.1.5.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.3HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card