CVE-2025-10853

Reflected Cross-Site Scripting (XSS) in Management Console of Multiple WSO2 Products Due to Improper Output Encoding

MEDIUM
6.1
CVSS Score
Published: November 5, 2025 at 07:21 PM UTC
Updated: June 17, 2026 at 08:29 AM UTC
13 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Open Banking IAM by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Open Banking IAM - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

A reflected cross-site scripting (XSS) vulnerability exists in the management console of multiple WSO2 products due to improper output encoding. By tampering with specific parameters, a malicious actor can inject arbitrary JavaScript into the response, leading to reflected XSS. Successful exploitation could result in UI manipulation, redirection to malicious websites, or data theft from the browser. However, session-related sensitive cookies are protected with the httpOnly flag, which mitigates the risk of session hijacking.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.274.5.0
Affected range stops below 4.5.0.27, so it looks safe — our inference, not a vendor statement
3.1.0 ≤ v < 3.1.0.3443.2.0 ≤ v < 3.2.0.4453.2.1 ≤ v < 3.2.1.654.0.0 ≤ v < 4.0.0.3654.1.0 ≤ v < 4.1.0.2274.2.0 ≤ v < 4.2.0.1674.3.0 ≤ v < 4.3.0.794.4.0 ≤ v < 4.4.0.434.5.0 ≤ v < 4.5.0.263.1.03.2.03.2.14.0.04.1.04.2.04.3.04.4.04.5.0
Affected range stops below 3.1.0.344, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.445, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.65, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.365, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.227, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.167, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.79, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.43, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.26, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
6.6.0 ≤ v < 6.6.0.2236.6.0
Affected range stops below 6.6.0.223, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
5.10.0 ≤ v < 5.10.0.3735.11.0 ≤ v < 5.11.0.4176.0.0 ≤ v < 6.0.0.2476.1.0 ≤ v < 6.1.0.2467.0.0 ≤ v < 7.0.0.1227.1.0 ≤ v < 7.1.0.295.10.05.11.06.0.06.1.07.0.07.1.0
Affected range stops below 5.10.0.373, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.417, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.247, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.246, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.122, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.29, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.3635.10.0
Affected range stops below 5.10.0.363, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.3932.0.0
Affected range stops below 2.0.0.393, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.4132.0.0
Affected range stops below 2.0.0.413, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
4.5.0 ≤ v < 4.5.0.254.5.0
Affected range stops below 4.5.0.25, so it looks safe — our inference, not a vendor statement
4.5.0 ≤ v < 4.5.0.254.5.0
Affected range stops below 4.5.0.25, so it looks safe — our inference, not a vendor statement
v ≥ 4.8.354.8.19 ≤ v < 4.8.19.54.8.21 ≤ v < 4.8.21.94.8.28 ≤ v < 4.8.28.34.8.30 ≤ v < 4.8.30.34.8.32 ≤ v < 4.8.32.14.8.33 ≤ v < 4.8.33.34.8.34 ≤ v < 4.8.34.34.8.194.8.214.8.284.8.304.8.324.8.334.8.344.8.35
Affected range stops below 4.8.19.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.21.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.28.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.30.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.32.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.33.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.34.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card