CVE-2025-0914

Velociraptor Shell Plugin Prevent_execve Bypass

LOW
3.8
CVSS Score
Published: February 27, 2025 at 04:07 PM UTC
Updated: June 17, 2026 at 08:27 AM UTC
1 product affected across 1 vendorVelociraptor

Using Velociraptor by Rapid7?

Get instant alerts when new vulnerabilities affect Velociraptor - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.73.4
Affected range stops below 0.73.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.8LOWrapid7
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-281

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card