CVE-2025-0127

PAN-OS: Authenticated Admin Command Injection Vulnerability in PAN-OS VM-Series

HIGH
7.1
CVSS Score
Published: April 11, 2025 at 02:01 AM UTC
Updated: June 17, 2026 at 08:25 AM UTC
1 product affected across 1 vendorPAN-OS

Using Cloud NGFW by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect Cloud NGFW - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

A command injection vulnerability in Palo Alto Networks PAN-OS® software enables an authenticated administrator to bypass system restrictions and run arbitrary commands as a root user. This issue is only applicable to PAN-OS VM-Series. This issue does not affect firewalls that are already deployed. Cloud NGFW and Prisma® Access are not affected by this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 10.1.14-h13, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 11.1.0 (unaffected)
Vendor states this is fixed in 11.2.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.1HIGHpalo_alto
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card